トップ「Cocoapods」の質問

CocoaPodsは、Cocoaプロジェクトの依存関係マネージャーです。

CocoaPodsをインストールするにはどうすればいいですか?

あまりにも多くのリンクを参照して試しましたが、成功しませんでした。 誰かアイデアがあれば教えてください。 私はカカオポッドのドキュメントを読み、何度もインストールを試みましたが、開始手順のために常に失敗しました。 最初にgemをインストールできないというエラーが1つ見つかりました。 誰かが私に1つずつ手順を教えてもらえますか? インストールまたはデモの方法。これは私が試した1つのリンクです。スクリーンショットは、私が与えられたこのコンソールエラーを示しています。

ios swift xcode rubygems cocoapods

プロジェクトからCocoaPodsを削除するにはどうすればよいですか?

プロジェクトからCocoaPodsを削除する正しい方法は何ですか? CocoaPod全体を削除したい。 クライアントによって課せられたいくつかの制限のため、私はそれを使用することができません。 xcworkspaceの代わりにxcodeprojが1つだけ必要です。

xcode cocoapods

AdMobにアプリケーションを配置した後、エラー「ライブラリが見つかりません」

アプリケーションをAdMobに配置した後、エラーが発生します。 アプリは今日まで機能していました。 エラーは次のとおりです。ld: library not found for -lGoogleAdMobAds clang: error: linker […] 続きを読む…

ios xcode admob cocoapods

アーキテクチャarm64の未定義のシンボル

CocoaPodsからファイルをインポートするたびにAppleMach-Oリンカーエラーが発生します。Undefined symbols for architecture arm64: "_OBJC_CLASS_$_FBSession", […] 続きを読む…

ios xcode xcode5 cocoapods

Xcode-ld:-lPodsのライブラリが見つかりません

iOSアプリケーションをビルドしようとすると、これらのエラーが発生します。ld: library not found for -lPods clang: error: linker […] 続きを読む…

ios objective-c xcode clang cocoapods

pod install -bash:pod:コマンドが見つかりません

少し前にpodをインストールしました。 ただし、動作が停止したため、再度作業を行っています。しかし、私はほとんどすぐにここで問題に遭遇します:pod install -bash: pod: command not found なぜこれが起こったのか提案はありますか?

cocoapods

CocoaPodsの最新バージョンに更新しますか?

プロジェクトへのAlamofire 4.0インストールで問題が発生しました。Swift 3を実行している最新バージョンのXcodeを入手しましたが、alamofireをインストールしようとすると、800のコンパイラエラーが発生します。どうやらAlamofire 4.0.0+をビルドするには、CocoaPods1.1.0 +が必要です。ターミナルにあるCocoaPodsのバージョンを調べたところ、1.0.1になっていると表示されます。CocoaPods 1.1はベータ版であるため、アップデートの実行は機能しませんでした。ですから、私が行きたいところまでそれを更新する方法が正確にはわかりません。 古くなっていない限り、800のコンパイラエラーのように強制されませんか? それは他の問題のように聞こえますか?

ios swift xcode cocoapods

エラー:RestKitをcocoapodsと一緒にインストールした後、「サンドボックスはPodfile.lockと同期していません...」

cocoapodsを使用してRestKitをインストールした後、奇妙な問題が発生しました。 cocoapodsを使用してプロジェクトのRestKit依存関係を解決し、ビルドしようとすると、次のエラーが発生します。サンドボックスはPodfile.lockと同期していません。 「podinstall」を実行するか、CocoaPodsインストールを更新します。pod install実行してみましたが、変更はありません。ここにいくつかのショットがあります: […] 続きを読む…

cocoapods restkit-0.20

CocoaPodsフレームワークのバージョンを確認する方法

CocoaPodsを介してFlurryを更新しましたが、Flurryが更新されたかどうかを確認するにはどうすればよいですか?私はターミナルが私にすべてが大丈夫であることを示したことを意味します:Installing FlurrySDK (4.2.3) Generating Pods project Integrating client […] 続きを読む…

ios version cocoapods

以前に追加したライブラリを削除またはアンインストールします:cocoapods

cocoapodsを介して外部フレームワークをiOSアプリケーションに追加しました。 そのライブラリをプロジェクトから削除するにはどうすればよいですか?

ios iphone ipad cocoapods