トップ「Rubygems」の質問

RubyGemsは、Rubyプログラミング言語用のパッケージ管理ツールです。

CocoaPodsをインストールするにはどうすればいいですか?

あまりにも多くのリンクを参照して試しましたが、成功しませんでした。 誰かアイデアがあれば教えてください。 私はカカオポッドのドキュメントを読み、何度もインストールを試みましたが、開始手順のために常に失敗しました。 最初にgemをインストールできないというエラーが1つ見つかりました。 誰かが私に1つずつ手順を教えてもらえますか? インストールまたはデモの方法。これは私が試した1つのリンクです。スクリーンショットは、私が与えられたこのコンソールエラーを示しています。

ios swift xcode rubygems cocoapods

パーミッションエラーで失敗した場合にgemをインストールまたはRubyGemsを更新する方法

gem install mygemを使用してgemをインストールしようとしていますが、 gem update --systemを使用してRubyGemsを更新しようとしていますが、次のエラーで失敗します。ERROR: While […] 続きを読む…

ruby macos rubygems

ローカルgemをインストールするにはどうすればよいですか?

.gemファイルをコンピューターのフォルダーにダウンロードした場合、後でgem installを使用してインストールできますか?

ruby rubygems

gemのプロキシサーバーを設定するにはどうすればよいですか?

コマンドプロンプトからSASSをインストールできません。以下の手順を試しましたc:\gem install sass 以下のエラーが発生します:ERROR: Could not find a […] 続きを読む…

windows proxy rubygems

mysql2のインストールエラー:gemネイティブ拡張のビルドに失敗しました

Railsにmysql2 gemをインストールしようとすると問題が発生します。 bundle installまたはgem install mysql2実行してインストールしようとすると、次のエラーが発生します。mysql2のインストール中にエラーが発生しました:エラー:gemネイティブ拡張機能のビルドに失敗しました。これを修正して […] 続きを読む…

mysql ruby-on-rails ruby rubygems mysql2

jsongemのインストール中にエラーが発生しました 'mkmf.rbはrubyのヘッダーファイルを見つけることができません'

コンテキストとしては、ファイアウォールのあるリモートサーバー上にあります。 プロキシを介して環境をセットアップしています。 私はruby 1.8.7を持っています。 geminstallを実行しようとすると..sudo gem install --http-proxy <host address>:& […] 続きを読む…

json ruby rubygems

--no-ri --no-rdocをgemインストールのデフォルトにする方法は?

自分のマシンまたは処理するサーバーにインストールしたgemからのRIまたはRDoc出力を使用しません(他のドキュメント手段を使用します)。--no-ri --no-rdocを設定するのを忘れたため、インストールするすべてのgemはデフォルトでRIとRDocのドキュメントをインストールします。これらの2つのフラグをデフォルトにする方法はありますか?

ruby rubygems

プロキシの背後からRubyGemsを更新するにはどうすればよいですか(ISA-NTLM)

私が背後にいるファイアウォールは、MicrosoftISAサーバーをNTLMのみのモードで実行しています。 Ruby SSPIgemまたは他の方法でRubygemをインストール/更新することに成功した人はいますか?...または私はただ怠惰ですか?注:rubysspi-1.2.4は機能しません。これは、IronRubyプロジェクトの一部である「igem」でも機能します

ruby proxy rubygems ironruby

gemファイルがインストールされている場所を見つける方法

gem listを使用してインストールされているgemを見つけることができますが、gemがインストールされている場所が表示されません。ジェムがどこにあるかをどのように見つけることができますか?また、ジェムをインストールする前に、それがインストールされる場所をどのように知ることができますか?

ruby rubygems

gem install:gemネイティブ拡張のビルドに失敗しました(ヘッダーファイルが見つかりません)

私はFedora14を使用しており、MySQLとMySQLサーバー5.1.42をインストールして実行しています。 今私はrootユーザーとしてこれをやろうとしました:gem install mysql しかし、私はこのエラーを受け取ります:Building native extensions. […] 続きを読む…

mysql ruby rubygems